Trying to install Drawbot as a module gives this error.



  • Hi! I'm trying to install Drawbot as a module via the Github README (using Python 3). I get a lot of errors of missing dependencies but installed these via pip3. After installing all the dependencies I end up with the error below while trying to install drawbot...

    Traceback (most recent call last):
      File "setup.py", line 17, in <module>
        import vanilla
      File "/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/vanilla/__init__.py", line 3, in <module>
        from vanilla.core import Hub
      File "/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/vanilla/core.py", line 102
        except Exception, e:
                        ^
    SyntaxError: invalid syntax
    

    Any thoughts?


  • admin

    I guess you have an other packages installed also called vanilla. Which is not the vanilla required by DrawBot...

    A similar issue see: https://github.com/robotools/vanilla/issues/88#issuecomment-464800669

    If you use pip to manage your packages, please use the requirements provided by drawbot.

    good luck



  • @frederik thanks!

    I've installed all dependencies with pip3 and installed Drawbot with python3 with no errors. But... When I try to build my Drawbot sketches in Sublime Text I get the following error.

    File "/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/drawBot-3.120-py3.7.egg/drawBot/drawBotDrawingTools.py", line 441, in DrawBotDrawingTool
        supportedOptions="\n        ".join(getContextOptionsDocs())
    TypeError: unsupported operand type(s) for %: 'NoneType' and 'dict'
    

    Could this be an error within the Drawbot package? Or am I missing a step here?


  • admin

    mm strange, can you send an example script that fails with this traceback

    A wild guess is that the drawBot package is not installed.

    Did you do this last step (next to installing all the dependencies)

    cd path/To/drawBot
    pytho3.7 setup.py install