hello @rachelkriebel, from your error message it looks like you have installed noise for Python 3.7. but DrawBot uses Python 3.6, so it can’t find it. you can specify the version of Python when installing a package with pip: pip3.6 install noise give it a try! good luck