Drawbot no longer working after upgrading to Catalina



  • I have installed drawbot as both a module and as a standalone app (as I did in the previous OS) but now neither seem to be working. I’ve done a clean install of python (3.7.4) and both drawbots and am getting a string of errors that seem to show up whenever a text() is used.

    Here’s an example of some of it (I can paste it all if that would be helpful:

    File "drawBot/drawBotDrawingTools.pyc", line 1623, in text
      File "drawBot/drawBotDrawingTools.pyc", line 1785, in textBox
      File "drawBot/context/baseContext.pyc", line 2351, in clippedText
      File "drawBot/context/baseContext.pyc", line 1203, in __getitem__
      File "drawBot/context/baseContext.pyc", line 930, in __init__
      File "drawBot/context/baseContext.pyc", line 938, in _setAttribute
      File "drawBot/context/baseContext.pyc", line 1377, in openTypeFeatures
      File "drawBot/context/baseContext.pyc", line 1391, in listOpenTypeFeatures
      File "drawBot/misc.pyc", line 362, in wrapper
      File "drawBot/context/tools/openType.pyc", line 509, in getFeatureTagsForFontName
      File "drawBot/context/tools/openType.pyc", line 495, in getFeatureTagsForDescriptions
      File "objc/_convenience_mapping.pyc", line 18, in __getitem__objectForKey_
      File "objc/_convenience.pyc", line 101, in container_unwrap
    KeyError: 'CTFeatureSelectorIdentifier'
    

  • admin

    CTFeatureSelectorIdentifier is not available anymore on 10.15, let me check


  • admin


  • admin

    get a pre-release version here http://static.typemytype.com/drawBot/DrawBot10.15.dmg

    see the pull request on github to see the changes and follow up the discussion



  • Great—thank you so much!



  • Any chance the Robofont Extension will be updated as well?